Faq warning saying the evriio.p file was p coded from an old Matlab version

From Eigenvector Research Documentation Wiki
Revision as of 11:25, 28 December 2018 by imported>Lyle (Created page with "===Issue:=== I get a warning saying the evriio.p file was p-coded from an old MATLAB version. ===Possible Solutions:=== If you receive the warning (or a similar warning) :...")
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

Issue:

I get a warning saying the evriio.p file was p-coded from an old MATLAB version.

Possible Solutions:

If you receive the warning (or a similar warning) :

Warning: The P-code file evriio.p was generated prior to MATLAB version 7.5 (R2007b) and will not be supported in a future release. Use pcode to regenerate evriio.p using MATLAB R2007b or later.

There are two solutions to this problem. The one to use depends on whether you have a full (non-expiring) license or a demo (expiring) license:

Full License

With a full PLS_Toolbox license, use the following steps to solve the problem.

  • Run evriinstall and follow the instructions to install PLS_Toolbox. After it is complete, restart Matlab and see if the warning messages are gone. If so, the problem is solved and you can ignore the remaining steps
  • Exit Matlab
  • Locate the PLS_Toolbox/utilities folder using your system's file browser (Explorer, Browser, etc)
  • Locate and rename the "evriio.p" file as "evriio_old.p" (Window 7 Users see note below)
  • Locate and rename the "evriio_2010b.p" file as "evriio.p"
  • Restart Matlab

The message should be gone after completing those steps. If not, contact our helpdesk at helpdesk@eigenvector.com .

NOTE: Window 7 users may find that they do not have sufficient permission to make these changes if PLS_Toolbox has been installed in a folder located under the "C:\Program Files folder" (as it would by default.) In these cases, the only solution may be to re-install PLS_Toolbox into a different folder such as one located in your personal Documents folder. Follow the directions for installing PLS_Toolbox located here but specify an alternative folder for installation.


Demo License

If you receive a similar message when using a demo license of PLS_Toolbox, the problem is that you have downloaded the wrong version of PLS_Toolbox. There are two "builds" of the software available from the "Download" tab of your account at http://download.eigenvector.com. The "Standard build" is designed for use on MATLAB versions 2007b and later. The "2007a build" is for MATLAB versions 2007a or earlier.

  1. Log into your account
  2. Choose to download PLS_Toolbox
  3. On the page asking for which version of the installer you want, choose the version for use with 2007b and later


Still having problems? Please contact our helpdesk at helpdesk@eigenvector.com