Analysis Window: Model Cache Pane

From Eigenvector Research Documentation Wiki
(Redirected from Model Cache)
Jump to navigation Jump to search

Table of Contents | Previous | Next

Analysis window Model Cache pane

Data that is used to create models and predictions during data analysis as well as all of the models and predictions created from this data is automatically cached. After a model is created, the model and the data used to create it are added to the cache. If new data is loaded and a prediction is made, this new data and the prediction are added to the cache. Every time you edit data and create a new model or prediction from the data, each version of the modified data and the corresponding model or prediction are added to the cache. The Model Cache pane displays this complete history of all your cached items-all of the data that was used to create models and predictions during data analysis as well as all of the models and predictions that were created from this data-in a hierarchical view.

Analysis window Model Cache pane
Model cache pane.png

To reload a previously created model:

  1. Set the Model Cache view to the mode which best organizes the list to help you find the item desired (see the Model Cache pane view descriptions for suggestions.)
  2. Locate the model to load in the list (Note that after other sorting criteria are met, models on a specific branch are sorted by date in all views.)
  3. Double-click on the old model to load it into the Analysis window. The calibration data corresponding to the model will also be automatically loaded (if it is available in the cache.) Right-clicking the model will give other options - see Manipulating cached items.

For more usage hints, see the Model Cache pane view descriptions below.

Note: By default, the Model Cache pane is turned on when Solo first opens. You can close the Model Cache pane by clicking the Close ("X") button in the upper right hand corner of the pane. To turn the Model Cache on again, on the Tools menu on the Analysis window, click View Cache, and then select a viewing option. Models and data are cached even if the Model Cache pane is not open.

Multiple options are available to you for changing the Model Cache view, managing your cache, and manipulating cache items. See:

Model Cache pane view

The options to change the Model Cache pane view are found in two locations:

  • In the Model Cache pane itself under Cache Settings and View
  • On the Tools menu (the View Cache option) for the Analysis windows
Options to change the Model Cache pane view
Model cache settings options.png

You can select from three different organizational views:

  • View Cache by Lineage-In the View Cache by Lineage view, the cache items are sorted by the parent data item. Under the parent data item, the child items (modified data, model, and predictions) are sorted by the timestamps at each modification point.
This is a convenient view to use in identifying a set of models which were all created from a specific data set or version of a data set (such as a specific data set with different sets of included variables and/or samples.)
View Cache by Lineage view
Model cache view lineage.png
  • View Cache by Date-In the View Cache by Date view, all cached items are simply sorted by creation date in chronological order.
This is a convenient view to use when attempting to locate a model or data which was used on a specific date. For example, to reload a model which you knew was built yesterday, switch to the Date view, locate yesterday's date, and expand the tree. All data and models used on that day will be listed. Reload any model by double-clicking it.
View Cache by Date view
Model cache view date.png
  • View Cache by Type-In the View Cache by Type view, all cached items are simply sorted by object type-data, model, or prediction.
This is a convenient view to use when attempting to locate a specific type of model when the data used and model's created date are not known. All data, models, and predictions are listed under their own branch, and then sorted by name (for data), type (for models and predictions), and date. For example, to locate an MCR model you know you created on some previous date, switch to the Type view, expand the Models branch, and locate the MCR models in that branch. You can then reload any model by double-clicking it.
View Cache by Type view
Model cache view type.png

Cache management

Several options are available to you for managing your cache. You can modify all of these options in the Options dialog box.

Note: For a detailed discussion about the Options dialog box, see Options dialog box.

1. Do one of the following:
  • In the Model Cache pane, expand the Cache Settings and View option, and under this option, click Edit Model Cache Settings.
Cache Settings and View options
Edit Model Cache settings paneoptions.png
  • On the Analysis window menu, click Edit > Options > Model Cache Settings.
The Options dialog box for the Model Cache pane opens.
Options dialog box
Options Model Cache dialogbox.png
2. Modify the value for any option, and then click OK.
The Options dialog box closes and you return to the Model Cache pane. Any changes that you made are effective immediately.

Option

Description

cache

Controls the operation of the cache. "On" records all data, models, and predictions. "readonly" locks down the cache and prevents recording to the cache and clearing of the cache.

project

Specifies an optional subfolder within the cachefolder for holding the cached items. The default name for project is "general." You can use the project setting to separate cached items among different work projects. Note: No option is available in Solo to delete a project folder after you create it. You can delete old project folders only by manually locating the project folder on your computer and deleting the folder. Note: You can also change value for the project setting using the Change Project option under Cache Settings and View in the Model Cache pane.

maxage

The maximum number of days an item is saved in the cache. An item that is older than this value is permanently deleted from the cache. Note: See "Manipulating cached items" below for information about saving cached items to a location other than the cachefolder.

maxdatasize

Specifies the maximum size of a data item (in total number of table elements) that can be stored in the cache.

Manipulating cached items

You can right-click on an entry for a cached item Model Cache pane to open a context menu that contains options for manipulating the item.

Menu Option

Description

View Details

Opens and displays the selected item in a separate window-either the DataSet Editor window or the Model Reader window.

Load

Loads the selected cached item into the Analysis window. By default, if no data is loaded into the Analysis window, then the cached item is loaded into the X calibration component; otherwise, you are prompted to override the loaded data or load the data to another location. Note: You can also double-click a cached item to load it into the Analysis window.

Load in New Window

Opens a new Analysis window and loads item same as Load above.

Export Cache Model

Save calibration data and model to a MAT file. These files can then be dragged and dropped onto an Analysis window to load.

Compare

Send a model to the Model Optimizer.

Save As

Save the cached item to the workspace or to a file.

Rename

Rename the cached item.

Remove From Cache

Remove selected item from the cache.

Moving/Changing a Cache

You can copy and move your Model Cache folder to a new location without any special consideration. When moving to a new computer, copy the cache folder to the new EVRI home folder and restart Matlab. In Solo, the location of the home folder can be found by selecting Help → About Solo. Once the folder is in the new location select File/Change Cache from the Workspace Browser and select the new folder. The cache will refresh automatically.

From the Workspace Browser File>Change Cache menu item. From the Matlab command line the cache folder location can be change with:

modelcache('changecachedir','path/to/new/location')

If you move your modelcache and experience problems getting the Model Cache to recognize the new location you may need to clear your preferences (matlabprefs.mat) file. Contact helpdesk@eigenvector.com for more details on how to do this.

The modelcache folder consists of the database folder and project folders. This folder and its contents are required to move/recover the model cache.

Cachefolder.jpg

Exporting and Importing Models

Models can be exported from the cache via the right-click menu Export For Cache item. This will export the model and the data used to create it (if available) to a MAT file. The file can then be Imported into a different cache. To import a cache model, expand the Cache Settings and View leaf and click the Import Model leaf. The model and data can also be loaded into an Analysis window by dragging and dropping the MAT file onto the window.

ImportExportCacheModel.jpg